One of the most powerful features of VidBlasterX is its modularity. By choosing the building stones you need, you can build the application that best suits your needs. These building stones are called modules, and can represent cameras, players, monitors etc. To add a module click Modules > Add in the main menu and select the module you want to add. Grab the title bar of the module to drag it to the required position. Grab the right or bottom border of the display to drag it to the required size. The collection of all modules, their positions and all their settings is called a profile.


The following commands are available in the main menu.


File > Load Profile

Loads previously saved profile from disk.


File > Save Profile

Saves current profile to disk.


File > Clear Profile

Removes all modules.


File > Lock Profile

When the profile is locked the main video resolution and frame rate cannot be changed and all modules are locked in place.


File > Exit

Exits program.


View > Macros

Opens the Macros editor.


View > Playout Controller

Opens the Playout controller.


View > Appearance > Full Desktop

Toggle between windowed and full desktop (all monitors) mode.


View > Appearance > Full Screen

Toggle between windowed and full screen (current monitor only) mode.


View > Advanced > API Command Stack

Used for debugging purposes. Opens the API window, showing the API command stack. All internal and external commands sent through the API can be monitored here. To prevent unnecessary delays, the window is only updated when visible.


View > Advanced > MIDI Event Log

Used for debugging purposes. Opens the MIDI event log, showing detected midi devices and notes/control codes received. To prevent unnecessary delays, the window is only updated when visible.


View > Advanced > VidBlasterX Log

Used for debugging purposes. Opens VidBlasterX's internal log.


View > Advanced > X-keys Event Log

Used for debugging purposes. Opens the X-keys event log, showing detected X-keys devices and data received. To prevent unnecessary delays, the window is only updated when visible.


Modules > Add

Add selected module.


Modules > Remove

Remove selected module.


Modules > Grid Size

Change the size of the grid. When moving modules they will snap to this grid when released.


Modules > Options > High Quality Scaling

Set/clear the High Quality Scaling option of selected/all video modules. When set, scaling down of video frames is drastically improved, but at the expense of resources (both memory bandwidth and CPU).


Settings > Video Resolution

Selects the main video resolution, i.e. the video resolution used internally by all modules (except those that have a setting that overwrites this locally). Note you should not change this setting while broadcasting, recording or streaming, or when the program's output is connected to another application or server.


Settings > Video Frame Rate

Select the main video frame rate, i.e. the frame rate used internally by all modules (except those that have a setting that overwrites this locally). Note you should not change this setting while broadcasting, recording or streaming, or when the program's output is connected to another application or server.


Settings > Audio Standard

Select the audio standard (EBU or SMPTE) used to convert analog audio levels to digital.


Help > Help

Opens the VidBlasterX help site in the default web browser.


Help > About

Displays the About window.


Help > Licence Key

Opens a dialog to enter your licence key.


Help > Check for Updates

Displays program's version number, and the version numbers of the latest release and beta versions.